Disponible Openbravo ERP 2.40MP1

Os dejo el código fuente de la versión 2.40.MP1 de Openbravo ERP, para instalarlo tan solo tenéis que seguir estos pasos.

Descomprimir y desempaquetar el archivo con:

tar xvfj 2.40mp1.tar.bz2

Luego configuramos los datos de conexión editando el archivo config/Openbravo.properties .

Una vez tengamos configurado el acceso a la base de datos ya podemos crearla:

ant database.lib

ant create.database

Ahora tenéis que construir las bibliotecas principales:

ant core.lib

ant trl.lib

ant wad.lib

Y por último compilamos, generamos el war y lo desplegamos:

ant compile.complete

ant war

ant deploy

Listo, como véis son los pasos de siempre.

Openbravo 2.40MP1 md5

 

Actualización: Si quieres obtener la última versión de la rama 2.40 ponte en contacto conmigo (cheli en aradaen.com).

 

Cheli

Comentarios

  1. manu

    Hola Cheli,

    Primero muchas gracias por compartir esto y segundo, hay algún modo de aplicar los fixes incluidos en MP1 y MP2 sobre una 240PROD existente?
    Hay alguna lista de fixes de estos releases?

    Muchas gracias de nuevo,
    Saludos,
    M

  2. Autor de la
    Entrada
    Cheli

    La forma de hacerlo es como ya he comentado en alguna ocasión, utilizando diff y patch. Es más, Openbravo tanto en network como con sus actualizadores no hace más que sacar ese diff, aplicarlo con patch y esperar a que no se produzca ningún conflicto cosa que siempre pasa, luego hace un ant update.database y recompila el código. La diferencia es que en network lo hacen con conary que es el gestor de paquetes de rpath y en la versión comunidad se utiliza un actualizador que preparan ellos.

    El listado de cambios de los MP lo puedes consultar en el wiki.

    Un saludo.

  3. Jaerhigo

    Hola Cheli:
    Llevo poco tiempo utilizando OB 2.4, y haber si me puedes explicar que tengo que configurar en config/Openbravo.properties ., corro en Ubuntu 8.04 y con Postgres 8.0

    Gracias y saludos.

  4. Autor de la
    Entrada
    Cheli

    Lo mejor es que para las siguientes veces preguntes en los foros de openbravo ya que yo estoy un tanto desconectado de estos temas. En config/setup-tools deberías tener una herramienta que te permita configurar este archivo.

    Saludos.

  5. Autor de la
    Entrada
    Cheli

    Ya no está, lo curioso es que quieras un MP tan temprano de una versión tan antigua, en todo caso sería más interesante que descargaras el último MP de la versión 2.40.

    Un saludo.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.